Email TLS certificate
Incident Report for Lunaria Ltd
Resolved
This incident has been resolved.
Posted Oct 01, 2021 - 09:04 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 01, 2021 - 09:03 UTC
Update
cPanel have released a patch that we have applied this morning. It may take some time for the certificate authorities to respond to all the renewal requests, but we expect the backlog to clear within 24 hours. If you continue to have issues with connecting to our email service using IMAP, please open a support ticket at https://support.lunaria.co.uk
Posted Oct 01, 2021 - 09:01 UTC
Identified
An additional workaround for mail client software (Outlook, Thunderbird etc) is to either:
Set encryption to TLS (Accept Any Certificate)
Or create an exception when prompted to do so by the mail client app or browser.
Posted Sep 30, 2021 - 19:37 UTC
Update
We are tracking updates on the issue here:
https://support.cpanel.net/hc/en-us/articles/4409770365335
Posted Sep 30, 2021 - 18:56 UTC
Investigating
It appears that today's TLS certificate update has caused a problem with the mail server returning an incorrect certificate for mail.yourdomain.com. We have opened a ticket with cPanel to investigate this further. In the meantime, if you have the issue, please use our webmail service at https://webmail.yourdomain.com
Posted Sep 30, 2021 - 18:54 UTC
This incident affected: Mail Server.