Potential connection issue
Incident Report for Lunaria Ltd
Resolved
This incident has been resolved.
Posted Jan 26, 2023 - 11:23 UTC
Investigating
We are currently working with our partner provider to investigate a potential issue affecting clients on the Sky Broadband network. Access to email may be affected.
Posted Jan 26, 2023 - 11:11 UTC
This incident affected: Mail Server.